CentOS7 升级Python2.x到3.x

CentOS 7 中默认安装了 Python,版本比较低(2.7.5),为了使用新版 3.x,需要对旧版本进行升级。由于很多基本的命令、软件包都依赖旧版本,比如:yum。所以,在更新 Python 时,建议不要删除旧版本(新旧版本可以共存)。

查看当前版本

[root@ansible ~]# python -V
Python 2.7.5

下载Python

进入python官网(https://www.python.org),选择需要的版本。此处我选择当前最新版本Python-3.9.7

[root@ansible soft]#yum install gcc gcc-c++ -y
[root@ansible soft]# wget https://www.python.org/ftp/python/3.9.7/Python-3.9.7.tar.xz
[root@ansible soft]# tar xvf Python-3.9.7.tar.xz 
[root@ansible soft]# cd Python-3.9.7
[root@ansible Python-3.6.1]# ./configure
[root@ansible Python-3.6.1]# make
[root@ansible Python-3.6.1]#make install

验证

#一个是旧版本,一个是新版本
[root@B6-15 ~]# python -V
Python 2.7.5
[root@B6-15 ~]# python3 -V
Python 3.9.7
[root@B6-15 ~]# 

设置3.X为默认版本

查看 Python 的路径,在 /usr/bin 下面。可以看到 python 链接的是 python 2.7,所以,执行 python 就相当于执行 python 2.7。

[root@B6-15 ~]# ls -al /usr/bin | grep python
lrwxrwxrwx    1 root root        37 8月  17 20:08 btpython -> /www/server/panel/pyenv/bin/python3.7
lrwxrwxrwx    1 root root         7 8月  17 20:04 python -> python2
lrwxrwxrwx    1 root root         9 8月  17 20:04 python2 -> python2.7
-rwxr-xr-x    1 root root      7144 11月 17 2020 python2.7

将原来 python 的软链接重命名:

mv /usr/bin/python /usr/bin/python.bak

将 python 链接至 python3:

ln -s /usr/local/bin/python3 /usr/bin/python

配置yum

升级 Python 之后,由于将默认的 python 指向了 python3,yum 不能正常使用,需要编辑 yum 的配置文件,此时:

[root@B6-15 ~]# yum list
  File "/usr/bin/yum", line 30
    except KeyboardInterrupt, e:
                            ^
SyntaxError: invalid syntax

修改

/usr/bin/yum

/usr/libexec/urlgrabber-ext-down

#!/usr/bin/python 改为 #!/usr/bin/python2.7,保存退出即可.


👋 感谢您的观看 Xy PRO!

© 版权声明
THE END
喜欢本站内容,请点【分享】【赞】和【收藏】~
点赞5
分享
评论 抢沙发
XyPro的头像-夕阳博客

昵称

取消
昵称表情代码图片